Reply to Thread
Results 1 to 6 of 6

Thread: ★ Snowy explorer coming back with no loot with active friend buff [23808]

  1. #1

    Join Date
    Sep 2020
    Posts
    23
    Monde
    Prestaging

    ★ Snowy explorer coming back with no loot with active friend buff [23808]

    I sent my snowy explorers out and then a few hours later decided to gem them to speed them up - they had 2 hours remaining to come back once I finished that and now I keep on getting them flash as coming back (about every minute). There is nothing in my mailbox.

    https://prnt.sc/vqu5o8

    https://prnt.sc/vqu6fm

    I do have a PFB applied but that is showing 14 hours left and was applied weeks ago.

    Note I am using new download.
    Last edited by donan; 27.11.20 at 01:36.

  2. #2

    Join Date
    Sep 2020
    Posts
    23
    Monde
    Prestaging
    Ok, the using gems isn't a factor. I sent them out again half on a prolonged with gems and the rest on a short without and they all came back within 5 minutes or so with no loot. I am not sure this is connected or not but when they come back there is also a quest that has popped up.

    And given all the quests I have sitting there on my test server account that is very often.

    ugh. the game lag is making me edit this again.

    Now it shows that two did come back with loot - I assume the two I sent on short searches without gems.
    Last edited by donan; 27.11.20 at 01:52.

  3. #3

    Join Date
    Feb 2012
    Posts
    253
    Monde
    Prestaging
    Isnt a bug well it is but its known you might have had pfb on for a while but the exp are new so are still affected sometimes by pfb till they sync ...i bought the snowy and didnt have any issues at all with them

  4. #4

    Join Date
    Sep 2020
    Posts
    23
    Monde
    Prestaging
    It is a bug they should be fixing. I sent them out about 5 or 6 times yesterday and only a few came back with loot.

    I actually haven't had a problem like this with other explorers and PFB. Come back once, yes maybe not that many times and to come back so fast with nothing.

  5. #5
    Blue Byte Team BB_Ondgrund's Avatar
    Join Date
    Mar 2020
    Posts
    106
    Monde
    Prestaging
    It is a known issue with newly bought explorers while the PFB is running. After buying the explorers, you have to log out for at least 15 minutes so the buff is applied correctly.

  6. #6

    Join Date
    Sep 2020
    Posts
    23
    Monde
    Prestaging
    Quote Originally Posted by BB_Ondgrund View Post
    It is a known issue with newly bought explorers while the PFB is running. After buying the explorers, you have to log out for at least 15 minutes so the buff is applied correctly.
    I am not sure this is the same problem. It is entirely possible I did log out because I bought those explorers and booked them and sent them on prolonged then I came back to the game a few hours later and decided to speed them up to see what they brought back. It is only then they started coming back.

    I play every event with PFB and have bought explorers almost every event and I have never encountered what I saw yesterday.

    In any case, any bugs that would result in people wasting gems I think should be a priority in fixing. Halloween event I bought 3 scared explorers and used gems to speed them up. I would not have been very happy if they had come back without loot.

Reply to Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Ubisoft uses cookies to ensure that you get the best experience on our websites. By continuing to use this site you agree to accept these cookies. More info on our privacy.